Allows close store easily from admin interface for some regions, based on GeoIP database. This is great security measure to prevent access to your store of potentially unreliable visitors. Requirements: X-Cart 4.0 PHP 4 (or PHP 5 with PHP 4 compatibility mode on) Safe mode turned off (normal for most hostings) 5 minutes time